Thursday, February 1, 2018

Region does not seem to be available error for AWS module boto.ec2

When you have this error, there is a good chance that your boto version is outdated. You will have to update the boto version by executing the below command:


pip install boto


This will install latest version of Boto framework which is 2.48.0. 

you can confirm by executing the below command:
pip list boto | grep boto

boto (2.48.0)
boto3 (1.5.22)
botocore (1.8.36) 

4 comments: